• 144969

    文章

  • 856

    评论

  • 13

    友链

  • 最近新加了换肤功能,大家多来逛逛吧~~~~
  • 喜欢这个网站的朋友可以加一下QQ群,我们一起交流技术。

pgdump低版本导出高版本数据库数据错误


有人在社区里经常会问到以下错误:

pg_dump: error: server version: 13.0; pg_dump version: 12.4
pg_dump: error: aborting because of server version mismatch

从错误中可以看到,低版本的pg_dump是不能导出高版本server中的数据的,这也是软件设计的一个基本思路。

所以遇到这个错误,您需要去找对应版本的pg_dump来导出其备份软件。

另外,高版本的pg_dump也能兼容导出低版本的server数据。

总结:

如果要从postgres server中导出数据,请使用对应版本的客户端pg_dump或者高版本的pg_dump工具。

 


695856371Web网页设计师②群 | 喜欢本站的朋友可以收藏本站,或者加入我们大家一起来交流技术!

0条评论

Loading...


发表评论

电子邮件地址不会被公开。 必填项已用*标注

自定义皮肤 主体内容背景
打开支付宝扫码付款购买视频教程
遇到问题联系客服QQ:419400980
注册梁钟霖个人博客