-->
  • 39865

    文章

  • 316

    评论

  • 27

    友链

  • 最近新加了换肤功能,大家多来逛逛吧~~~~
  • 喜欢这个网站的朋友可以加一下QQ群,我们一起交流技术。

Static interface methods are only supported starting with Android N (--min-api 24):

喜欢本站的朋友可以收藏本站,或者加入QQ群:172816590Web网页设计师,我们大家一起来交流技术!

欢迎来到梁钟霖个人博客网站。本个人博客网站提供最新的站长新闻,各种互联网资讯。 还提供个人博客模板,最新最全的java教程,java面试题。在此我将尽我最大所能将此个人博客网站做的最好! 谢谢大家,愿大家一起进步!

Android studio 导入依赖, 构建时报错

错误如下 : 

Static interface methods are only supported starting with Android N (--min-api 24): void butterknife.Unbinder.lambda$static$0()
Message{kind=ERROR, text=Static interface methods are only supported starting with Android N (--min-api 24): void butterknife.Unbinder.lambda$static$0(), sources=[Unknown source file], tool name=Optional.of(D8)}

提示的意思是 最小api应为24 , 实验 将最小 api版本改为26后, 能在 Android  O 的设备上运行,

但是由于App 肯定不能只适配 8.0以上的设备 , 所以还得另寻方法

最后发现这问题都是因为没有指定jdk 1.8而产生的

在app build:gradle 中的android 下添加 指定jdk版本的代码,如下:

android {
    ......
    //指定jdk版本
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
}

 



您觉喜欢本网站,或者觉得本文章对您有帮助,那么可以选择打赏。
打赏多少,您高兴就行,谢谢您对梁钟霖这小子的支持! ~(@^_^@)~

  • 微信扫一扫

    微信打赏
  • 支付宝扫一扫

    支付宝打赏
转载原创文章请注明出处,转载至: 梁钟霖个人博客www.liangzl.com

0条评论

Loading...


发表评论

电子邮件地址不会被公开。 必填项已用*标注

自定义皮肤